icon-rss-large

中文泛技术类IT博客 | 留言

软路由 | 硬路由 | 网站地图 |

DDNS动态域名脚本(花生壳+3322公云)for ROS 6.x(转)

发表于 2016年08月28日 软路由版

一、花生壳
花生壳动态域名是全球用户量最大的完全免费的动态域名解析软件(DDNS)。当您安装并注册花生壳动态域名解析软件,无论您在任何地点、任何时间、使用任 何线路,均可利用这一服务建立拥有固定域名和最大自主权的互联网主机。“花生壳动态域名解析软件”支持的线路包括普通电话线、ISDN、ADSL、有线电 视网络、双绞线到户的宽带网和其它任何能够提供互联网真实IP的接入服务线路,而无论连接获得的IP属于动态还是静态。
现在花生壳动态域名解析软件为千万的域名提供动态域名解析服务,并广泛应用于网站建设、视频监控、遥感测绘、FTP、VPN、企业OA、ERP等应用领域。

脚本:

local ipaddr
local server “http://ddns.oray.com
local domain “域名”
local par “/ph/update?&hostname=$domain&myip=$ipaddr”
local users “用户”
local paswd “密码”
:set ipaddr [/ip address get [/ip address find interface=pppoe-out2] address]
:set ipaddr [:pick $ipaddr 0 ([len $ipaddr] -3)]
/tool fetch url=($server . $par) mode=http user=$users password=$paswd



二、3322

脚本:


:local ednsuser “用户”
:local ednspass “密码”
:local ednshost “域名”
:local ednsinterface “接口”
:local members “http://members.3322.org/dyndns/update?system=dyndns
#:local members “http://members./nic/update?”
:local status
:local status [/interface get [/interface find name=$ednsinterface] running]
:if ($status!=false) do={
:local ednslastip [:resolve $ednshost]
:if ([ :typeof $ednslastip ] = nil ) do={ :local ednslastip “0” }
:local ednsiph [ /ip address get [/ip address find interface=$ednsinterface ] address ]
:local ednsip [:pick $ednsiph 0 [:find $ednsiph “/”]]
:local ednsstr “&hostname=$ednshost&myip=$ednsip”
:if ($ednslastip != $ednsip) do={/tool fetch url=($members . $ednsstr) mode=http user=$ednsuser password=$ednspass dst-path=$ednshost
:delay 2
:local result [/file get $ednshost contents]
:log info ($ednshost . ” ” .$result)
/file remove $ednshost ;
}
}


本文标题:DDNS动态域名脚本(花生壳+3322公云)for ROS 6.x(转)
本文链接:http://www.666global.com/index.php/post/920.html
作者授权:除特别说明外,本文由 citywo 原创编译并授权 大城小我 刊载发布。
版权声明:本文不使用任何协议授权,您可以任何形式自由转载或使用。
0
留言区
留言区

易彩快3 www.3043.org-福彩刮刮乐天天中| www.31827.com-重庆十分彩-| www.88524.cc-578彩票官网| www.060084.com-福建福彩快三一定牛| www.198773.com-乐彩三d17500| www.282678.com-七星彩中奖技巧| www.470091.com-76彩票-| www.563505.com-5分快三砍龙| www.644636.com-足彩最新伤停情况| www.758120.com-福彩能在微信上买吗| www.860767.com-福彩快3安徽查询| www.926577.com-幸运赛马彩票app| www.989740.com-7070彩票网| www.kg7.cc-彩票吉林快三| www.rv64.com-一定牛彩票11选5| www.18dj.com-彩票如何玩-| www.365.hk-天天爱彩票老版本| www.4726.org-南宁青秀区福利彩票| www.09066.com-快三稳定盈利计划| www.57439.com-美容投彩是什么骗局| www.051735.com-下载大发快三时时彩| www.139844.com-盈彩是官网-| www.223465.com-河南快三玩法规则| www.306026.com-六利彩开奖结果查询| www.383225.com-体彩一九年第29期| www.543289.com-今天福彩3d诗句| www.634849.com-福彩双色球彩票应用| www.732517.com-新郑和庄镇彩礼| www.811935.com-苏州竞彩店转让赶集| www.890208.com-时时彩购买软件网址| www.956558.com-彩票破译-| 中彩网www.81233e.com| www.ig38.com-幸运快三手机版下载| www.c77.club-百宝彩票平台| www.38mj.com-动物彩铅简笔画| www.1850.net-uu快三客服电话| www.8841.net-网上时时彩-| www.45876.cc-中华福彩app| www.93628.com-如何玩江苏快三| www.065898.com-彩库宝典下载并安装| www.137086.com-七彩意匠涂料| www.218505.com-广西好运彩开奖| www.296159.com-彩票双色球开奖时间| www.373228.com-南京快三竞猜| www.480736.com-取消和彩云-| www.563530.com-q彩网购彩大厅| www.636948.com-彩虹emoji-| www.816857.com-特彩吧天下彩免费料| www.883146.com-没有彩排-| 500彩票www.50074j.com| www.gp14.com-大发快3分分彩计划| www.yv96.com-红旗彩票app| www.26qo.com-北京福彩加盟条件| www.0752.ren-福彩三d图库大全| www.7413.vip-色彩斑斓的释义| www.25933.cc-篮球彩票网站| www.69596.com-九九集团快三| www.056092.com-分分快三怎么赌| www.137939.com-中国彩票最大奖排行| www.218200.com-注册彩票送388元| www.290977.com-福彩3d条件专区| www.365163.cc-江苏快三还有加奖么| www.456061.com-668彩票合法吗| www.547682.com-体彩e彩-| www.681414.com-劝别买彩票-| www.761534.com-快三抓豹子有规律吗| www.863068.com-泰安体彩转让信息| www.930294.com-今晚福利彩票结果| www.979251.com-好彩蓝莓-| www.xh71.cc-彩虹六号手机版| www.18wl.cc-体彩店微信代打| www.050.in-石家庄福彩中奖| www.3573.biz-南方双彩下载和安装| www.9047.pw-今晚七星彩出什么码| www.58311.com-彩票cp10-| www.018493.com-彩票55倍-| www.087236.com-3d福彩走势图带线| www.153299.com-够力七星彩奖表电脑| www.261920.com-福彩快三输了| www.350558.com-彩色铅笔蝴蝶| www.433516.com-彩票中奖者的经验| www.526963.com-英国幸运五星彩走势| www.632123.com-网络时时彩害人| www.701395.com-五亿彩票网咋么样| www.777743.com-中彩票706-| www.881558.com-辉煌彩票网站导航| www.961648.com-11进5是哪种彩票| 8号彩票www.81520u.com| www.fp55.com-腾讯彩票500万| www.xb08.com-开心七星彩票论坛| www.14ly.com-双彩讨论-| www.603.cm-福利彩票十五选五| www.4325.in-福彩兑奖中心在哪里| www.9485.cc-什么彩票5位数| www.60176.com-福彩三d校长预测| www.017902.com-南宁体彩兑奖中心| www.085084.com-臺湾福星彩图| www.144965.com-福彩时时乐官网| www.252391.com-关于买彩票的新闻| www.320428.com-江苏快三倍投死| www.386047.com-瑞彩祥云平台租用| www.525218.com-分分彩背后操作| www.604962.com-中澳彩票是合法吗| www.672916.com-中围彩吧-| www.742599.com-好运彩怎么下载| www.808866.com-竞彩任选九专家预测| www.879262.com-彩票安卓版12选5| www.979014.com-中彩网首页彩票| www.iw3.com-福彩藏机图-| www.oc10.com-多赢彩票官网网址| www.2qg.com-彩票提成是多少钱| www.55cq.cc-体彩重庆百变王牌| www.844.org-南国体彩经典彩版| www.4622.vip-一万买彩票-| www.9547.cc-海南彩票开发公司| www.71581.com-彩票里什么叫刷子| www.027736.com-体彩大乐透中奖| www.097698.com-澳门基金六福彩| www.158004.com-足彩电脑版-| www.258500.com-中国竞彩资讯| www.325863.com-星彩网论坛-| www.388937.com-福彩姜子牙复式图| www.525165.com-圣地彩杀一码| www.601836.com-彩票冒领报警| www.666459.com-福彩快三内蒙古| www.733093.com-南京市体育彩票中心| www.800038.cc-体彩大乐透计算公式| www.868377.com-七星彩规律怎么看的| www.973436.com-彩虹抖音翻唱| 超级彩票www.811756.com| www.il15.com-新浪爱彩德甲| www.xs21.com-数字彩票出号规律| www.12bq.com-胜负彩二等奖| www.73lh.com-天空彩开奖结果| www.0730.org-360蛋蛋彩票软件| www.32105.cc-快三算赌博-| www.69486.cc-云购彩票平台靠谱吗| www.030006.com-内蒙体彩十一选五| www.097620.com-彩票中奖准备| www.152316.com-完美彩票app| www.251966.com-旺彩app软件下载| www.313895.com-福彩3d电子彩报| www.372966.com-七乐彩专家分析| www.452267.com-五星彩店邀请码| www.531676.com-彩搜网专业彩搜彩票| www.650670.com-天津时时采彩官网| www.723662.com-神彩福牛专家预测| www.788972.com-竞彩必发指数新浪| www.854492.com-福彩3d喜中-| www.907170.com-彩票7位数中5位| www.963239.com-彩铅画入门图片| 中国福利彩票www.34788l.com| www.bq77.com-幸运时时彩计划网| www.qp36.cc-福利彩票有哪几种| www.04ni.com-容易临摹的彩铅名画| www.63xb.com-彩票x技术-| www.878.date-一定牛内蒙快三预测| www.4254.com-好彩赢三张官方下载| www.8833.top-福利彩票七乐彩选号| www.61322.com-彩票开奖结果app| www.010093.com-体彩手机在线大管家| www.067118.com-彩票网站建设制作| www.123629.com-福彩3d秘密通道| www.182536.com-宁夏快三中奖技巧|